wallet-core/packages/taler-wallet-cli/debian/rules
2023-02-25 12:35:24 +01:00

37 lines
894 B
Makefile
Executable File

#!/usr/bin/make -f
include /usr/share/dpkg/default.mk
TALER_WALLET_HOME = /usr/share/taler-wallet-cli
build: build-arch build-indep
build-arch:
true
build-indep:
true
override_dh_auto_install:
dh_install bin/taler-wallet-cli.mjs $(TALER_WALLET_HOME)/node_modules/taler-wallet-cli/bin
dh_install dist/taler-wallet-cli-bundled.cjs $(TALER_WALLET_HOME)/node_modules/taler-wallet-cli/dist
dh_install dist/taler-wallet-cli-bundled.cjs.map $(TALER_WALLET_HOME)/node_modules/taler-wallet-cli/dist
dh_link $(TALER_WALLET_HOME)/node_modules/taler-wallet-cli/bin/taler-wallet-cli.mjs /usr/bin/taler-wallet-cli
override_dh_builddeb:
dh_builddeb -- -Zgzip
binary:
dh $@
binary-arch:
dh $@
binary-indep:
dh $@
clean:
true
# Override this step because it's very slow and likely
# unnecessary for us.
override_dh_strip_nondeterminism:
true
get-orig-source:
uscan --force-download --rename